WordPress + IE 6.0 = Crap

Obviously as seemed from this blog, one should not use Internet Explorer 6.0 to read it.